Jump to content
LemmeCheck.Info

Arylia PHP 7.X Development and Demo


Recommended Posts

edendom
13 minutes ago, Hincapie said:

Thank you so much for the praise and donations, its really really nice when the work is appreciated.

I dont know everyone but I reply to those I can recognice - but otherwise Robert also has the php7x upgraded files (including the batching fix)....and of course, if you find any bugs please do yell here or directly to me so we can get them fixed.

We can also look at putting together requests for new features/changes - but maybe Robert should collect those and then we can see
 

I can't thank you enough, I receive the new zip, made a backup, overwrite old files except config.inc.php 

All works like a charm for me thanks a lot!

Link to post
Share on other sites
  • 4 weeks later...
naughty1

Ok i meesed up somewhere  tried test gallery  it made the tunbs and images  correctly  HOWEVER it didnt create an index.php   also when i try to add new sponsor it doesnt add it.   Any Ideas?

 

on help screen all is green 

Screenshot_1.jpg

Link to post
Share on other sites
naughty1

Ok i meesed up somewhere  tried test gallery  it made the tunbs and images  correctly  HOWEVER it didnt create an index.php   also when i try to add new sponsor it doesnt add it.   Any Ideas?

get this  too MySQL query failed: Field 'entryId' doesn't have a default value

on help screen all is green 

Link to post
Share on other sites
Robert

@Naughty1: make sure you specify the path to where the galleries are to be built in the Admin / settings tab. And then verify that folder is writeable.

When you say the pictures and thumbs are created, are you going by the Thumbnails tab during the build process and seeing the thumbs there? Or are you looking inside the built galleries folder and seeing them in there?

I ask because the only time I've ever heard of a gallery's index not getting written is because the built-galleries path was incorrect, or was not writeable.

Link to post
Share on other sites
naughty1

Robert  yeah the thumbs and images are in the folder  but no index php  and the gallery doesn't show in my list of galleries  once its created  also cant add sponsors  

Link to post
Share on other sites
Robert

That is really weird. I tested it on an install of php7.2 and it worked well. It's weird that the images can be written to a folder, but the index file cannot (the index file is the last part of the gallery creation step, which then stores it in the database. Without that file being built, it won't show in your galleries list.

Try building a gallery using default.php -- if this works, then the gallery builder works, and it's template related.

I'm really unsure why you would be unable to add a sponsor. Perhaps Hincapie has an idea about that. That's not something I am able to replicate here to see what might have caused it.

Link to post
Share on other sites
naughty1

Debug output:

createFolder:1:.
getHtml:2:..
getImages:19:...................
renameMedia:2:..
createThumbs:17:.................
resizeOriginals:17:.................
createPreview:1:.
saveGallery:2:X

 

as you can see here  thumbs  images  are created 

 

 

test gallery output in ftp.jpg

Link to post
Share on other sites
Robert

That is interesting, I've never seen that before. The only thing I can possibly think of is that a php excecution error is occuring during the building of the page, using the provided template, causing the build routine to exit prematurely and, thus, no template file/index written.

To confirm, this is using the Arylia version available from myself or Hincapie, which is revised specifically for php 7.2.x, and being run on a server using php 7.2? And NOT the one available in the downloads area?

I ask because I don't recall sending you the version for php 7.2.x, unless Hincapie sent it  you. This version is not available in the Arylia downloads area here, it must be sent by either myself or Hincapie.

 

Link to post
Share on other sites
naughty1

Yeah hincapie sent it to me,  I think we have same host   mojo  so if he pops in maybe he can let me know if they had to make any adjustments

Link to post
Share on other sites
Robert

MOJO are actually extremely good with support. Certainly, it's my host of choice. They might be able to quickly check error logs and rule out any issues with ownership/permissions.

That said, Hincapie generally pops in daily so I'm sure he'll see this when he does.

Link to post
Share on other sites
Hincapie

Heya - sorry hadnt noticed the action.

First step - try asking mojo, they might indeed be able to identify what is going wrong

If that fails - i dont have a "shoot from the hip" reason but will be happy to look into it....pm me phpmyadmin, arylia admin and ftp access (i know scary, but its very hard to see "from the outside" what exactly is going on)

Link to post
Share on other sites
  • 5 months later...

Hello,

Just moved to a new server with php7.

If I donate to you is there any chance I can download the update to update my Arylia scripts?

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. policies